CVE-2014-9028
CVE-2014-9028
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap-based buffer overflow in stream_decoder.c in libFLAC before 1.3.1 allows remote attackers to execute arbitrary code via a crafted .flac file.
EPSS 9.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
flac Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.0-3
Update to 1.3.0-3
flac Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.0-3
Update to 1.3.0-3
flac Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.0-3
Update to 1.3.0-3
flac Ubuntu:14.04:LTS
- Versions
- 1.3.0-1
- 1.3.0-2
- Affected ranges
- ECOSYSTEM: < 1.3.0-2ubuntu0.14.04.1
Update to 1.3.0-2ubuntu0.14.04.1
Original sources
- http://rhn.redhat.com/errata/RHSA-2015-0767.html
- http://packetstormsecurity.com/files/129261/libFLAC-1.3.0-Stack-Overflow-Heap-Overflow-Code-Execution.html
- http://www.ubuntu.com/usn/USN-2426-1
- http://www.securityfocus.com/archive/1/534083/100/0/threaded
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:188
- http://www.debian.org/security/2014/dsa-3082
- https://git.xiph.org/?p=flac.git%3Ba=commit%3Bh=fcf0ba06ae12ccd7c67cee3c8d948df15f946b85
- http://advisories.mageia.org/MGASA-2014-0499.html
- http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:239
- http://lists.opensuse.org/opensuse-updates/2014-12/msg00034.html
- http://www.ocert.org/advisories/ocert-2014-008.html
- http://www.securityfocus.com/bid/71282
- https://nvd.nist.gov/vuln/detail/CVE-2014-9028