CVE-2014-9030
CVE-2014-9030
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The do_mmu_update function in arch/x86/mm.c in Xen 3.2.x through 4.4.x does not properly manage page references, which allows remote domains to cause a denial of service by leveraging control over an HVM guest and a crafted MMU_MACHPHYS_UPDATE.
EPSS 2.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.1-4
Update to 4.4.1-4
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.1-4
Update to 4.4.1-4
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.1-4
Update to 4.4.1-4
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 4.4.1-0ubuntu0.14.04.2
Update to 4.4.1-0ubuntu0.14.04.2
Original sources
- http://xenbits.xen.org/xsa/advisory-113.html
- https://security.gentoo.org/glsa/201504-04
- http://secunia.com/advisories/62672
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98853
- http://www.debian.org/security/2015/dsa-3140
- http://www.securityfocus.com/bid/71207
- http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00010.html
- https://nvd.nist.gov/vuln/detail/CVE-2014-9030