CVE-2014-9621
CVE-2014-9621
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The ELF parser in file 5.16 through 5.21 allows remote attackers to cause a denial of service via a long string.
EPSS 3.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
file Debian:12
- Affected ranges
- ECOSYSTEM: < 1:5.21+15-1
Update to 1:5.21+15-1
file Debian:13
- Affected ranges
- ECOSYSTEM: < 1:5.21+15-1
Update to 1:5.21+15-1
file Debian:14
- Affected ranges
- ECOSYSTEM: < 1:5.21+15-1
Update to 1:5.21+15-1
file Ubuntu:14.04:LTS
- Versions
- 5.11-2ubuntu4
- 1:5.14-2ubuntu1
- 1:5.14-2ubuntu2
- 1:5.14-2ubuntu3
- 1:5.14-2ubuntu3.1
- 1:5.14-2ubuntu3.2
- 1:5.14-2ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 1:5.14-2ubuntu3.4
Update to 1:5.14-2ubuntu3.4
Original sources
- http://www.openwall.com/lists/oss-security/2015/01/17/9
- https://usn.ubuntu.com/3686-1/
- http://mx.gw.com/pipermail/file/2014/001654.html
- http://mx.gw.com/pipermail/file/2015/001660.html
- https://security.gentoo.org/glsa/201503-08
- http://advisories.mageia.org/MGASA-2015-0040.html
- https://github.com/file/file/commit/65437cee25199dbd385fb35901bc0011e164276c
- https://nvd.nist.gov/vuln/detail/CVE-2014-9621