p PatchFirst

CVE-2014-9652

CVE-2014-9652

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The mconvert function in softmagic.c in file before 5.21, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not properly handle a certain string-length field during a copy of a truncated version of a Pascal string, which might allow remote attackers to cause a denial of service (out-of-bounds memory access and application crash) via a crafted file.

EPSS 5.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • file Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:5.21+15-1

    Update to 1:5.21+15-1

  • file Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:5.21+15-1

    Update to 1:5.21+15-1

  • file Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:5.21+15-1

    Update to 1:5.21+15-1

  • file Ubuntu:14.04:LTS

    Versions
    • 5.11-2ubuntu4
    • 1:5.14-2ubuntu1
    • 1:5.14-2ubuntu2
    • 1:5.14-2ubuntu3
    • 1:5.14-2ubuntu3.1
    • 1:5.14-2ubuntu3.2
    Affected ranges
    • ECOSYSTEM: < 1:5.14-2ubuntu3.3

    Update to 1:5.14-2ubuntu3.3

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.6

    Update to 5.5.9+dfsg-1ubuntu4.6

Original sources

Check your server →