CVE-2015-1855
CVE-2015-1855
This page contains facts from public vulnerability sources. Check the original advisory before updating.
verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers via vectors related to (1) multiple wildcards, (1) wildcards in IDNA names, (3) case sensitivity, and (4) non-ASCII characters.
CVSS 5.9 · Medium · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby
- Versions
- before 2.0.0 patchlevel 645: Affected
- 2.1.x before 2.1.6: Affected
- and 2.2.x before 2.2.2: Affected
No fix published
ruby1.9.1 Ubuntu:14.04:LTS
- Versions
- 1.9.3.194-8.1ubuntu2
- 1.9.3.448-1ubuntu1
- 1.9.3.448-1ubuntu2
- 1.9.3.484-1ubuntu1
- 1.9.3.484-1ubuntu2
- 1.9.3.484-2ubuntu1
- 1.9.3.484-2ubuntu1.1
- 1.9.3.484-2ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 1.9.3.484-2ubuntu1.3
Update to 1.9.3.484-2ubuntu1.3
ruby2.0 Ubuntu:14.04:LTS
- Versions
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.4
Update to 2.0.0.484-1ubuntu2.4
Original sources
- http://www.debian.org/security/2015/dsa-3247
- http://www.debian.org/security/2015/dsa-3245
- http://www.debian.org/security/2015/dsa-3246
- https://www.ruby-lang.org/en/news/2015/04/13/ruby-openssl-hostname-matching-vulnerability/
- https://puppetlabs.com/security/cve/cve-2015-1855
- https://bugs.ruby-lang.org/issues/9644
- https://nvd.nist.gov/vuln/detail/CVE-2015-1855