CVE-2015-2319
CVE-2015-2319
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The TLS stack in Mono before 3.12.1 makes it easier for remote attackers to conduct cipher-downgrade attacks to EXPORT_RSA ciphers via crafted TLS traffic, related to the "FREAK" issue, a different vulnerability than CVE-2015-0204.
CVSS 7.5 · High · EPSS 3.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mono Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.8+dfsg-10
Update to 3.2.8+dfsg-10
mono Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.8+dfsg-10
Update to 3.2.8+dfsg-10
mono Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.8+dfsg-10
Update to 3.2.8+dfsg-10
mono Ubuntu:14.04:LTS
- Versions
- 2.10.8.1-5ubuntu2
- 3.2.3+dfsg-5
- 3.2.3+dfsg-7ubuntu1
- 3.2.8+dfsg-4ubuntu1
- Affected ranges
- ECOSYSTEM: < 3.2.8+dfsg-4ubuntu1.1
Update to 3.2.8+dfsg-4ubuntu1.1
Original sources
- http://www.ubuntu.com/usn/USN-2547-1
- http://www.securityfocus.com/bid/73250
- https://bugzilla.redhat.com/show_bug.cgi?id=1202869
- https://mitls.org/pages/attacks/SMACK#freak
- http://www.openwall.com/lists/oss-security/2015/03/17/9
- http://www.mono-project.com/news/2015/03/07/mono-tls-vulnerability/
- https://www.debian.org/security/2015/dsa-3202
- https://github.com/mono/mono/commit/9c38772f094168d8bfd5bc73bf8925cd04faad10
- https://nvd.nist.gov/vuln/detail/CVE-2015-2319