p PatchFirst

PatchFirst · Latest vulnerabilities

mono vulnerabilities

Vulnerabilities published for mono in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 18

  1. CVE-2012-3382

    Not ratedEPSS 1.91%Fix available

    CVE-2012-3382

    Cross-site scripting (XSS) vulnerability in the ProcessRequest function in mcs/class/System.Web/System.Web/HttpForbiddenHandler.cs in Mono 2.10.8 and earlier allows remote attackers to inject arbitrary web script or HTML via a file with a crafted name and a forbidden extension, which is not properly handled in an error message.

    • Update to 2.10.8.1-5
    Published Updated
  2. CVE-2010-1459

    Not ratedEPSS 1.93%Fix available

    CVE-2010-1459

    The default configuration of ASP.NET in Mono before 2.6.4 has a value of FALSE for the EnableViewStateMac property, which allows remote attackers to conduct cross-site scripting (XSS) attacks, as demonstrated by the __VIEWSTATE parameter to 2.0/menu/menu1.aspx in the XSP sample project.

    • Update to 2.4.4~svn151842-3
    Published Updated
  3. CVE-2009-0217

    Not ratedEPSS 6.36%Fix available

    CVE-2009-0217

    The design of the W3C XML Signature Syntax and Processing (XMLDsig) recommendation, as implemented in products including (1) the Oracle Security Developer Tools component in Oracle Application Server 10.1.2.3, 10.1.3.4, and 10.1.4.3IM; (2) the WebLogic Server component in BEA Product Suite 10.3, 10.0 MP1, 9.2 MP3, 9.1, 9.0, and 8.1 SP6; (3) Mono before 2.4.2.2; (4) XML Security Library before 1.2.12; (5) IBM WebSphere Application Server Versions 6.0 through 6.0.2.33, 6.1 through 6.1.0.23, and 7.0 through 7.0.0.1; (6) Sun JDK and JRE Update 14 and earlier; (7) Microsoft .NET Framework 3.0 through 3.0 SP2, 3.5, and 4.0; and other products uses

    • Update to 2.4.2.3+dfsg-1
    Published Updated
  4. CVE-2009-0689

    Not ratedEPSS 28.05%Public exploitFix available

    CVE-2009-0689

    Array index error in the (1) dtoa implementation in dtoa.c (aka pdtoa.c) and the (2) gdtoa (aka new dtoa) implementation in gdtoa/misc.c in libc, as used in multiple operating systems and products including in FreeBSD 6.4 and 7.2, NetBSD 5.0, OpenBSD 4.5, Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4, K-Meleon 1.5.3, SeaMonkey 1.1.8, and other products, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large precision value in the format argument to a printf function, which triggers incorrect memory allocation and a heap-based buffer overflow during conve

    • Update to 4.2.1.102+dfsg2-4
    Published Updated
  5. CVE-2008-3422

    Not ratedEPSS 1.55%Fix available

    CVE-2008-3422

    Multiple cross-site scripting (XSS) vulnerabilities in the ASP.net class libraries in Mono 2.0 and earlier allow remote attackers to inject arbitrary web script or HTML via crafted attributes related to (1) HtmlControl.cs (PreProcessRelativeReference), (2) HtmlForm.cs (RenderAttributes), (3) HtmlInputButton (RenderAttributes), (4) HtmlInputRadioButton (RenderAttributes), and (5) HtmlSelect (RenderChildren).

    • Update to 1.9.1+dfsg-4
    Published Updated
  6. CVE-2006-6104

    Not ratedEPSS 5.25%Public exploitFix available

    CVE-2006-6104

    The System.Web class in the XSP for ASP.NET server 1.1 through 2.0 in Mono does not properly verify local pathnames, which allows remote attackers to (1) read source code by appending a space (%20) to a URI, and (2) read credentials via a request for Web.Config%20.

    • Update to 1.2.2.1-1
    Published Updated
  7. CVE-2005-0509

    Not ratedEPSS 15.95%Fix available

    CVE-2005-0509

    Multiple cross-site scripting (XSS) vulnerabilities in the Mono 1.0.5 implementation of ASP.NET (.Net) allow remote attackers to inject arbitrary HTML or web script via Unicode representations for ASCII fullwidth characters that are converted to normal ASCII characters, including ">" and "<".

    • Update to 1.1.6-4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →