p PatchFirst

CVE-2015-2325

CVE-2015-2325

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The compile_branch function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code, cause a denial of service (out-of-bounds heap read and crash), or possibly have other unspecified impact via a regular expression with a group containing a forward reference repeated a large number of times within a repeated outer group that has a zero minimum quantifier.

CVSS 7.8 · High · EPSS 1.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:8.35-7.2

    Update to 2:8.35-7.2

  • pcre3 Ubuntu:14.04:LTS

    Versions
    • 1:8.31-2
    • 1:8.31-2ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1:8.31-2ubuntu2.1

    Update to 1:8.31-2ubuntu2.1

Original sources

Check your server →