p PatchFirst

CVE-2015-2326

CVE-2015-2326

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The pcre_compile2 function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code and cause a denial of service (out-of-bounds read) via regular expression with a group containing both a forward referencing subroutine call and a recursive back reference, as demonstrated by "((?+1)(\1))/".

CVSS 5.5 · Medium · EPSS 1.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:8.35-7.2

    Update to 2:8.35-7.2

  • pcre3 Ubuntu:14.04:LTS

    Versions
    • 1:8.31-2
    • 1:8.31-2ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1:8.31-2ubuntu2.1

    Update to 1:8.31-2ubuntu2.1

Original sources

Check your server →