p PatchFirst

CVE-2015-2716

CVE-2015-2716

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in the XML parser in Mozilla Firefox before 38.0, Firefox ESR 31.x before 31.7, and Thunderbird before 31.7 allows remote attackers to execute arbitrary code by providing a large amount of compressed XML data, a related issue to CVE-2015-1283.

EPSS 7.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • firefox Ubuntu:14.04:LTS

    Versions
    • 24.0+build1-0ubuntu1
    • 25.0+build3-0ubuntu0.13.10.1
    • 28.0~b2+build1-0ubuntu2
    • 28.0+build1-0ubuntu1
    • 28.0+build2-0ubuntu1
    • 28.0+build2-0ubuntu2
    • 29.0+build1-0ubuntu0.14.04.2
    • 30.0+build1-0ubuntu0.14.04.3
    • 31.0+build1-0ubuntu0.14.04.1
    • 32.0+build1-0ubuntu0.14.04.1
    • 32.0.3+build1-0ubuntu0.14.04.1
    • 33.0+build2-0ubuntu0.14.04.1
    • 34.0+build2-0ubuntu0.14.04.1
    • 35.0+build3-0ubuntu0.14.04.2
    • 35.0.1+build1-0ubuntu0.14.04.1
    • 36.0+build2-0ubuntu0.14.04.4
    • 36.0.1+build2-0ubuntu0.14.04.1
    • 36.0.4+build1-0ubuntu0.14.04.1
    • 37.0+build2-0ubuntu0.14.04.1
    • 37.0.1+build1-0ubuntu0.14.04.1
    • 37.0.2+build1-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 38.0+build3-0ubuntu0.14.04.1

    Update to 38.0+build3-0ubuntu0.14.04.1

  • thunderbird Ubuntu:14.04:LTS

    Versions
    • 1:24.0+build1-0ubuntu1
    • 1:24.0+build1-0ubuntu2
    • 1:24.1.1+build1-0ubuntu0.13.10.1
    • 1:24.1.1+build1-0ubuntu1
    • 1:24.2.0+build1-0ubuntu1
    • 1:24.4.0+build1-0ubuntu1
    • 1:24.5.0+build1-0ubuntu0.14.04.1
    • 1:24.6.0+build1-0ubuntu0.14.04.1
    • 1:31.0+build1-0ubuntu0.14.04.1
    • 1:31.1.1+build1-0ubuntu0.14.04.1
    • 1:31.1.2+build1-0ubuntu0.14.04.1
    • 1:31.2.0+build2-0ubuntu0.14.04.1
    • 1:31.3.0+build1-0ubuntu0.14.04.1
    • 1:31.4.0+build1-0ubuntu0.14.04.1
    • 1:31.5.0+build1-0ubuntu0.14.04.1
    • 1:31.6.0+build1-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 1:31.7.0+build1-0ubuntu0.14.04.1

    Update to 1:31.7.0+build1-0ubuntu0.14.04.1

Original sources

Check your server →