CVE-2015-2730
CVE-2015-2730
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mozilla Network Security Services (NSS) before 3.19.1, as used in Mozilla Firefox before 39.0, Firefox ESR 31.x before 31.8 and 38.x before 38.1, and other products, does not properly perform Elliptical Curve Cryptography (ECC) multiplications, which makes it easier for remote attackers to spoof ECDSA signatures via unspecified vectors.
EPSS 3.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
nss Debian:12
- Affected ranges
- ECOSYSTEM: < 2:3.19.1-1
Update to 2:3.19.1-1
nss Debian:13
- Affected ranges
- ECOSYSTEM: < 2:3.19.1-1
Update to 2:3.19.1-1
nss Debian:14
- Affected ranges
- ECOSYSTEM: < 2:3.19.1-1
Update to 2:3.19.1-1
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 39.0+build5-0ubuntu0.14.04.1
Update to 39.0+build5-0ubuntu0.14.04.1
nss Ubuntu:14.04:LTS
- Versions
- 2:3.15.1-1ubuntu1
- 2:3.15.2-1
- 2:3.15.3-1
- 2:3.15.3.1-1
- 2:3.15.3.1-1.1
- 2:3.15.3.1-1.1ubuntu1
- 2:3.15.4-1ubuntu3
- 2:3.15.4-1ubuntu4
- 2:3.15.4-1ubuntu5
- 2:3.15.4-1ubuntu6
- 2:3.15.4-1ubuntu7
- 2:3.15.4-1ubuntu7.1
- 2:3.17-0ubuntu0.14.04.1
- 2:3.17.1-0ubuntu0.14.04.1
- 2:3.17.1-0ubuntu0.14.04.2
- 2:3.17.4-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 2:3.19.2-0ubuntu0.14.04.1
Update to 2:3.19.2-0ubuntu0.14.04.1
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- 1:31.4.0+build1-0ubuntu0.14.04.1
- 1:31.5.0+build1-0ubuntu0.14.04.1
- 1:31.6.0+build1-0ubuntu0.14.04.1
- 1:31.7.0+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:31.8.0+build1-0ubuntu0.14.04.1
Update to 1:31.8.0+build1-0ubuntu0.14.04.1
Original sources
- http://www.oracle.com/technetwork/topics/security/ovmbulletinjul2016-3090546.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00033.html
- http://www.securityfocus.com/bid/83399
- https://security.gentoo.org/glsa/201512-10
- http://www.debian.org/security/2015/dsa-3336
- http://www.securityfocus.com/bid/75541
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.ubuntu.com/usn/USN-2672-1
- http://rhn.redhat.com/errata/RHSA-2015-1699.html
- http://www.mozilla.org/security/announce/2015/mfsa2015-64.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00034.html
- https://developer.mozilla.org/docs/Mozilla/Projects/NSS/NSS_3.19.1_release_notes
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00031.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1125025
- http://rhn.redhat.com/errata/RHSA-2015-1664.html
- http://www.ubuntu.com/usn/USN-2656-1
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00021.html
- http://www.securitytracker.com/id/1032783
- http://www.ubuntu.com/usn/USN-2656-2
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-2730