p PatchFirst

CVE-2015-3165

CVE-2015-3165

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.

EPSS 8.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • postgresql-9.1 Ubuntu:14.04:LTS

    Versions
    • 9.1.10-1
    • 9.1.10-1bzr1
    • 9.1.11-1
    • 9.1.11-2
    • 9.1.12-1
    • 9.1.13-1
    • 9.1.14-0ubuntu0.14.04
    • 9.1.15-0ubuntu0.14.04
    Affected ranges
    • ECOSYSTEM: < 9.1.16-0ubuntu0.14.04

    Update to 9.1.16-0ubuntu0.14.04

  • postgresql-9.3 Ubuntu:14.04:LTS

    Versions
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    • 9.3.3-1
    • 9.3.3-1bzr1
    • 9.3.3-1bzr2
    • 9.3.4-1
    • 9.3.5-0ubuntu0.14.04.1
    • 9.3.6-0ubuntu0.14.04
    Affected ranges
    • ECOSYSTEM: < 9.3.7-0ubuntu0.14.04

    Update to 9.3.7-0ubuntu0.14.04

Original sources

Check your server →