p PatchFirst

CVE-2015-3210

CVE-2015-3210

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based buffer overflow in PCRE 8.34 through 8.37 and PCRE2 10.10 allows remote attackers to execute arbitrary code via a crafted regular expression, as demonstrated by /^(?P=B)((?P=B)(?J:(?P<B>c)(?P<B>a(?P=B)))>WGXCREDITS)/, a different vulnerability than CVE-2015-8384.

CVSS 9.8 · Critical · EPSS 9.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:8.35-7.2

    Update to 2:8.35-7.2

Original sources

Check your server →