CVE-2015-3218
CVE-2015-3218
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The authentication_agent_new function in polkitbackend/polkitbackendinteractiveauthority.c in PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (NULL pointer dereference and polkitd daemon crash) by calling RegisterAuthenticationAgent with an invalid object path.
EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
policykit-1 Debian:12
- Affected ranges
- ECOSYSTEM: < 0.105-11
Update to 0.105-11
policykit-1 Debian:13
- Affected ranges
- ECOSYSTEM: < 0.105-11
Update to 0.105-11
policykit-1 Debian:14
- Affected ranges
- ECOSYSTEM: < 0.105-11
Update to 0.105-11
policykit-1 Ubuntu:14.04:LTS
- Versions
- 0.105-3ubuntu3
- 0.105-4ubuntu1
- 0.105-4ubuntu2
- 0.105-4ubuntu2.14.04.1
- 0.105-4ubuntu3.14.04.1
- Affected ranges
- ECOSYSTEM: < 0.105-4ubuntu3.14.04.2
Update to 0.105-4ubuntu3.14.04.2
Original sources
- http://lists.freedesktop.org/archives/polkit-devel/2015-May/000420.html
- https://usn.ubuntu.com/3717-1/
- http://lists.fedoraproject.org/pipermail/package-announce/2015-July/161721.html
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00042.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-July/162294.html
- http://lists.freedesktop.org/archives/polkit-devel/2015-July/000432.html
- http://www.securityfocus.com/bid/76086
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00010.html
- http://www.securitytracker.com/id/1035023
- http://lists.freedesktop.org/archives/polkit-devel/2015-May/000421.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-3218