p PatchFirst

PatchFirst · Latest vulnerabilities

policykit-1 vulnerabilities

Vulnerabilities published for policykit-1 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 17

  1. CVE-2026-4897

    Medium · CVSS 5.5EPSS 0.16%Fix available

    Polkit: polkit: denial of service via unbounded input processing through standard input

    A flaw was found in polkit. A local user can exploit this by providing a specially crafted, excessively long input to the `polkit-agent-helper-1` setuid binary via standard input (stdin). This unbounded input can lead to an out-of-memory (OOM) condition, resulting in a Denial of Service (DoS) for the system.

    • Update to 127-3
    Published Updated
  2. CVE-2025-7519

    Medium · CVSS 6.7EPSS 0.22%Fix available

    Polkit: xml policy file with a large number of nested elements may lead to out-of-bounds write

    A flaw was found in polkit. When processing an XML policy with 32 or more nested elements in depth, an out-of-bounds write can be triggered. This issue can lead to a crash or other unexpected behavior, and arbitrary code execution is not discarded. To exploit this flaw, a high-privilege account is needed as it's required to place the malicious policy file properly.

    • Update to 127-1
    Published Updated
  3. CVE-2021-4115

    Medium · CVSS 5.5EPSS 0.53%Fix available

    CVE-2021-4115

    There is a flaw in polkit which can allow an unprivileged user to cause polkit to crash, due to process file descriptor exhaustion. The highest threat from this vulnerability is to availability. NOTE: Polkit process outage duration is tied to the failing process being reaped and a new one being spawned

    • Update to 0.105-32
    Published Updated
  4. CVE-2021-3560

    High · CVSS 7.8EPSS 23.71%In KEVPublic exploitFix available

    CVE-2021-3560

    It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 0.105-31
    Published Updated
  5. CVE-2021-4034

    High · CVSS 7.8EPSS 94.92%In KEVPublic exploitFix available

    CVE-2021-4034

    A local privilege escalation vulnerability was found on polkit's pkexec utility. The pkexec application is a setuid tool designed to allow unprivileged users to run commands as privileged users according predefined policies. The current version of pkexec doesn't handle the calling parameters count correctly and ends trying to execute environment variables as commands. An attacker can leverage this by crafting environment variables in such a way it'll induce pkexec to execute arbitrary code. When successfully executed the attack can cause a local privilege escalation given unprivileged users administrative rights on the target machine.

    • Update to 0.105-31.1
    Published Updated
  6. CVE-2018-1116

    Medium · CVSS 4.7EPSS 1.2%Fix available

    CVE-2018-1116

    A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.

    • Update to 0.105-21
    Published Updated
  7. CVE-2015-3218

    Not ratedEPSS 0.43%Fix available

    CVE-2015-3218

    The authentication_agent_new function in polkitbackend/polkitbackendinteractiveauthority.c in PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (NULL pointer dereference and polkitd daemon crash) by calling RegisterAuthenticationAgent with an invalid object path.

    • Update to 0.105-11
    Published Updated
  8. CVE-2013-4288

    Not ratedEPSS 0.34%Fix available

    CVE-2013-4288

    Race condition in PolicyKit (aka polkit) allows local users to bypass intended PolicyKit restrictions and gain privileges by starting a setuid or pkexec process before the authorization check is performed, related to (1) the polkit_unix_process_new API function, (2) the dbus API, or (3) the --process (unix-process) option for authorization to pkcheck.

    • Update to 0.105-3+nmu1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →