CVE-2015-3223
CVE-2015-3223
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The ldb_wildcard_compare function in ldb_match.c in ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles certain zero values, which allows remote attackers to cause a denial of service (infinite loop) via crafted packets.
CVSS 5.3 · Medium · EPSS 6.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.1.22+dfsg-1
Update to 2:4.1.22+dfsg-1
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.1.22+dfsg-1
Update to 2:4.1.22+dfsg-1
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.1.22+dfsg-1
Update to 2:4.1.22+dfsg-1
ldb Ubuntu:14.04:LTS
- Versions
- 1:1.1.15-1.1
- 1:1.1.16-1
- Affected ranges
- ECOSYSTEM: < 1:1.1.16-1ubuntu0.1
Update to 1:1.1.16-1ubuntu0.1
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- Affected ranges
- ECOSYSTEM: < 2:4.1.6+dfsg-1ubuntu2.14.04.11
Update to 2:4.1.6+dfsg-1ubuntu2.14.04.11
ldb Ubuntu:16.04:LTS
- Versions
- 2:1.1.20-2
- 2:1.1.21-1
- 2:1.1.23-1
- 2:1.1.23-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2:1.1.24-1ubuntu1
Update to 2:1.1.24-1ubuntu1
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- Affected ranges
- ECOSYSTEM: < 2:4.3.3+dfsg-1ubuntu1
Update to 2:4.3.3+dfsg-1ubuntu1
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1290287
- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/174391.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00042.html
- http://www.ubuntu.com/usn/USN-2855-2
- https://www.samba.org/samba/security/CVE-2015-3223.html
- http://www.ubuntu.com/usn/USN-2856-1
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00019.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00020.html
- http://www.securityfocus.com/bid/79731
- https://git.samba.org/?p=samba.git%3Ba=commit%3Bh=ec504dbf69636a554add1f3d5703dd6c3ad450b8
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00032.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/174076.html
- http://www.securitytracker.com/id/1034493
- http://www.debian.org/security/2016/dsa-3433
- https://git.samba.org/?p=samba.git%3Ba=commit%3Bh=aa6c27148b9d3f8c1e4fdd5dd46bfecbbd0ca465
- https://security.gentoo.org/glsa/201612-47
- http://www.ubuntu.com/usn/USN-2855-1
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00033.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-3223