p PatchFirst

PatchFirst · Latest vulnerabilities

ldb vulnerabilities

Vulnerabilities published for ldb in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2022-32746

    Medium · CVSS 5.4EPSS 1.32%No fix published

    CVE-2022-32746

    A flaw was found in the Samba AD LDAP server. The AD DC database audit logging module can access LDAP message values freed by a preceding database module, resulting in a use-after-free issue. This issue is only possible when modifying certain privileged attributes, such as userAccountControl.

    Published Updated
  2. CVE-2020-27840

    High · CVSS 7.5EPSS 3.83%Fix available

    CVE-2020-27840

    A flaw was found in samba. Spaces used in a string around a domain name (DN), while supposed to be ignored, can cause invalid DN strings with spaces to instead write a zero-byte into out-of-bounds memory, resulting in a crash. The highest threat from this vulnerability is to system availability.

    • Update to 2:1.1.24-1ubuntu3.2
    Published Updated
  3. CVE-2021-20277

    High · CVSS 7.5EPSS 4.33%Fix available

    CVE-2021-20277

    A flaw was found in Samba's libldb. Multiple, consecutive leading spaces in an LDAP attribute can lead to an out-of-bounds memory write, leading to a crash of the LDAP server process handling the request. The highest threat from this vulnerability is to system availability.

    • Update to 2:1.1.24-1ubuntu3.2
    Published Updated
  4. CVE-2019-3824

    Medium · CVSS 6.5EPSS 2.82%Fix available

    CVE-2019-3824

    A flaw was found in the way an LDAP search expression could crash the shared LDAP server process of a samba AD DC in samba before version 4.10. An authenticated user, having read permissions on the LDAP server, could use this flaw to cause denial of service.

    • Update to 2:1.1.24-1ubuntu3.1
    Published Updated
  5. CVE-2015-5330

    High · CVSS 7.5EPSS 6.11%Fix available

    CVE-2015-5330

    ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles string lengths, which allows remote attackers to obtain sensitive information from daemon heap memory by sending crafted packets and then reading (1) an error message or (2) a database value.

    • Update to 2:1.1.24-1ubuntu1
    Published Updated
  6. CVE-2015-3223

    Medium · CVSS 5.3EPSS 6.88%Fix available

    CVE-2015-3223

    The ldb_wildcard_compare function in ldb_match.c in ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles certain zero values, which allows remote attackers to cause a denial of service (infinite loop) via crafted packets.

    • Update to 2:1.1.24-1ubuntu1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →