p PatchFirst

CVE-2015-3228

CVE-2015-3228

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in the gs_heap_alloc_bytes function in base/gsmalloc.c in Ghostscript 9.15 and earlier allows remote attackers to cause a denial of service (crash) via a crafted Postscript (ps) file, as demonstrated by using the ps2pdf command, which triggers an out-of-bounds read or write.

EPSS 3.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.15~dfsg-1

    Update to 9.15~dfsg-1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.15~dfsg-1

    Update to 9.15~dfsg-1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.15~dfsg-1

    Update to 9.15~dfsg-1

  • ghostscript Ubuntu:14.04:LTS

    Versions
    • 9.10~dfsg-0ubuntu2
    • 9.10~dfsg-0ubuntu3
    • 9.10~dfsg-0ubuntu4
    • 9.10~dfsg-0ubuntu5
    • 9.10~dfsg-0ubuntu6
    • 9.10~dfsg-0ubuntu7
    • 9.10~dfsg-0ubuntu8
    • 9.10~dfsg-0ubuntu9
    • 9.10~dfsg-0ubuntu10
    • 9.10~dfsg-0ubuntu10.1
    • 9.10~dfsg-0ubuntu10.2
    • 9.10~dfsg-0ubuntu10.3
    Affected ranges
    • ECOSYSTEM: < 9.10~dfsg-0ubuntu10.4

    Update to 9.10~dfsg-0ubuntu10.4

Original sources

Check your server →