p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities

Vulnerabilities published for ghostscript in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 54

  1. CVE-2019-3835

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-3835

    It was found that the superexec operator was available in the internal dictionary in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.

    • Update to 9.26~dfsg+0-0ubuntu0.14.04.8
    Published Updated
  2. CVE-2019-3838

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-3838

    It was found that the forceput operator could be extracted from the DefineResource method in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.

    • Update to 9.26~dfsg+0-0ubuntu0.14.04.8
    Published Updated
  3. USN-3866-3

    Not ratedFix available

    ghostscript regression

    USN-3866-2 fixed a regression in Ghostscript. The Ghostscript update introduced a new regression that resulted in certain pages being printed with a blue background. This update fixes the problem. Original advisory details: Tavis Ormandy discovered that Ghostscript incorrectly handled certain PostScript files. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use this issue to access arbitrary files, execute arbitrary code, or cause a denial of service.

    • Update to 9.26~dfsg+0-0ubuntu0.14.04.7
    Published Updated
  4. USN-3866-2

    Not ratedFix available

    ghostscript regression

    USN-3866-1 fixed vulnerabilities in Ghostscript. The new Ghostscript version introduced a regression when printing certain page sizes. This update fixes the problem. Original advisory details: Tavis Ormandy discovered that Ghostscript incorrectly handled certain PostScript files. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use this issue to access arbitrary files, execute arbitrary code, or cause a denial of service.

    • Update to 9.26~dfsg+0-0ubuntu0.14.04.5
    Published Updated
  5. CVE-2018-19134

    High · CVSS 7.8EPSS 2.87%Fix available

    CVE-2018-19134

    In Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.

    • Update to 9.26~dfsg+0-0ubuntu0.14.04.1
    Published Updated
  6. USN-3831-2

    Not ratedFix available

    ghostscript regression

    USN-3831-1 fixed vulnerabilities in Ghostscript. Ghostscript 9.26 introduced a regression when used with certain options. This update fixes the problem. Original advisory details: It was discovered that Ghostscript contained multiple security issues. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use these issues to access arbitrary files, execute arbitrary code, or cause a denial of service.

    • Update to 9.26~dfsg+0-0ubuntu0.14.04.3
    Published Updated
  7. CVE-2018-16802

    High · CVSS 7.8EPSS 2.09%Fix available

    CVE-2018-16802

    An issue was discovered in Artifex Ghostscript before 9.25. Incorrect "restoration of privilege" checking when running out of stack during exception handling could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction. This is due to an incomplete fix for CVE-2018-16509.

    • Update to 9.10~dfsg-0ubuntu10.13
    Published Updated
  8. CVE-2018-16585

    High · CVSS 7.8EPSS 1.72%Fix available

    CVE-2018-16585

    An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193)

    • Update to 9.10~dfsg-0ubuntu10.13
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →