p PatchFirst

CVE-2015-4141

CVE-2015-4141

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.

EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3-2.2

    Update to 2.3-2.2

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3-2.2

    Update to 2.3-2.2

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3-2.2

    Update to 2.3-2.2

  • wpa Ubuntu:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.3

    Update to 2.1-0ubuntu1.3

Original sources

Check your server →