p PatchFirst

CVE-2015-4144

CVE-2015-4144

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The EAP-pwd server and peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not validate that a message is long enough to contain the Total-Length field, which allows remote attackers to cause a denial of service (crash) via a crafted message.

EPSS 3.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3-2.2

    Update to 2.3-2.2

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3-2.2

    Update to 2.3-2.2

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3-2.2

    Update to 2.3-2.2

  • wpa Ubuntu:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.3

    Update to 2.1-0ubuntu1.3

Original sources

Check your server →