CVE-2015-4488
CVE-2015-4488
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Use-after-free vulnerability in the StyleAnimationValue class in Mozilla Firefox before 40.0, Firefox ESR 38.x before 38.2, and Firefox OS before 2.2 allows remote attackers to have an unspecified impact by leveraging a StyleAnimationValue::operator self assignment.
EPSS 3.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 40.0+build4-0ubuntu0.14.04.1
Update to 40.0+build4-0ubuntu0.14.04.1
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- 1:31.4.0+build1-0ubuntu0.14.04.1
- 1:31.5.0+build1-0ubuntu0.14.04.1
- 1:31.6.0+build1-0ubuntu0.14.04.1
- 1:31.7.0+build1-0ubuntu0.14.04.1
- 1:31.8.0+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:38.2.0+build1-0ubuntu0.14.04.1
Update to 1:38.2.0+build1-0ubuntu0.14.04.1
Original sources
- http://www.debian.org/security/2015/dsa-3410
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00025.html
- http://www.ubuntu.com/usn/USN-2712-1
- http://lists.opensuse.org/opensuse-updates/2015-08/msg00031.html
- http://www.ubuntu.com/usn/USN-2702-3
- http://rhn.redhat.com/errata/RHSA-2015-1682.html
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00014.html
- http://lists.opensuse.org/opensuse-updates/2015-08/msg00030.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1176270
- http://rhn.redhat.com/errata/RHSA-2015-1586.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00016.html
- http://www.securitytracker.com/id/1033247
- http://www.ubuntu.com/usn/USN-2702-2
- http://www.ubuntu.com/usn/USN-2702-1
- https://security.gentoo.org/glsa/201605-06
- http://www.securitytracker.com/id/1033372
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00021.html
- http://www.debian.org/security/2015/dsa-3333
- http://www.mozilla.org/security/announce/2015/mfsa2015-90.html
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00015.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-4488