CVE-2015-4506
CVE-2015-4506
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow in the vp9_init_context_buffers function in libvpx, as used in Mozilla Firefox before 41.0 and Firefox ESR 38.x before 38.3, allows remote attackers to execute arbitrary code via a crafted VP9 file.
EPSS 4.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libvpx Debian:12
- Affected ranges
- ECOSYSTEM: < 1.4.0-4
Update to 1.4.0-4
libvpx Debian:13
- Affected ranges
- ECOSYSTEM: < 1.4.0-4
Update to 1.4.0-4
libvpx Debian:14
- Affected ranges
- ECOSYSTEM: < 1.4.0-4
Update to 1.4.0-4
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 41.0+build3-0ubuntu0.14.04.1
Update to 41.0+build3-0ubuntu0.14.04.1
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- 1:31.4.0+build1-0ubuntu0.14.04.1
- 1:31.5.0+build1-0ubuntu0.14.04.1
- 1:31.6.0+build1-0ubuntu0.14.04.1
- 1:31.7.0+build1-0ubuntu0.14.04.1
- 1:31.8.0+build1-0ubuntu0.14.04.1
- 1:38.2.0+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:38.3.0+build1-0ubuntu0.14.04.1
Update to 1:38.3.0+build1-0ubuntu0.14.04.1
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00004.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1192226
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00005.html
- http://www.ubuntu.com/usn/USN-2754-1
- http://www.ubuntu.com/usn/USN-2743-4
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.ubuntu.com/usn/USN-2743-3
- http://rhn.redhat.com/errata/RHSA-2015-1834.html
- http://www.ubuntu.com/usn/USN-2743-2
- http://www.securitytracker.com/id/1033640
- http://www.debian.org/security/2015/dsa-3365
- http://www.securityfocus.com/bid/76816
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00000.html
- http://www.ubuntu.com/usn/USN-2743-1
- http://www.mozilla.org/security/announce/2015/mfsa2015-101.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-4506