p PatchFirst

CVE-2015-5289

CVE-2015-5289

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple stack-based buffer overflows in json parsing in PostgreSQL before 9.3.x before 9.3.10 and 9.4.x before 9.4.5 allow attackers to cause a denial of service (server crash) via unspecified vectors, which are not properly handled in (1) json or (2) jsonb values.

EPSS 5.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • postgresql-9.1 Ubuntu:14.04:LTS

    Versions
    • 9.1.10-1
    • 9.1.10-1bzr1
    • 9.1.11-1
    • 9.1.11-2
    • 9.1.12-1
    • 9.1.13-1
    • 9.1.14-0ubuntu0.14.04
    • 9.1.15-0ubuntu0.14.04
    • 9.1.16-0ubuntu0.14.04
    • 9.1.17-0ubuntu0.14.04
    • 9.1.18-0ubuntu0.14.04
    Affected ranges
    • ECOSYSTEM: < 9.1.19-0ubuntu0.14.04

    Update to 9.1.19-0ubuntu0.14.04

  • postgresql-9.3 Ubuntu:14.04:LTS

    Versions
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    • 9.3.3-1
    • 9.3.3-1bzr1
    • 9.3.3-1bzr2
    • 9.3.4-1
    • 9.3.5-0ubuntu0.14.04.1
    • 9.3.6-0ubuntu0.14.04
    • 9.3.7-0ubuntu0.14.04
    • 9.3.8-0ubuntu0.4.04
    • 9.3.9-0ubuntu0.14.04
    Affected ranges
    • ECOSYSTEM: < 9.3.10-0ubuntu0.14.04

    Update to 9.3.10-0ubuntu0.14.04

Original sources

Check your server →