CVE-2015-5314
CVE-2015-5314
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The eap_pwd_process function in eap_server/eap_server_pwd.c in hostapd 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when used with (1) an internal EAP server or (2) a RADIUS server and EAP-pwd is enabled in a runtime configuration, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
CVSS 5.9 · Medium · EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wpa Debian:12
- Affected ranges
- ECOSYSTEM: < 2.3-2.3
Update to 2.3-2.3
wpa Debian:13
- Affected ranges
- ECOSYSTEM: < 2.3-2.3
Update to 2.3-2.3
wpa Debian:14
- Affected ranges
- ECOSYSTEM: < 2.3-2.3
Update to 2.3-2.3
wpa Ubuntu:14.04:LTS
- Versions
- 1.0-3ubuntu2
- 1.0-3ubuntu3
- 1.0-3ubuntu4
- 2.1-0ubuntu1
- 2.1-0ubuntu1.1
- 2.1-0ubuntu1.2
- 2.1-0ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 2.1-0ubuntu1.4
Update to 2.1-0ubuntu1.4