p PatchFirst

CVE-2015-6251

CVE-2015-6251

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Double free vulnerability in GnuTLS before 3.3.17 and 3.4.x before 3.4.4 allows remote attackers to cause a denial of service via a long DistinguishedName (DN) entry in a certificate.

EPSS 19.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.3.17-1

    Update to 3.3.17-1

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.3.17-1

    Update to 3.3.17-1

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.3.17-1

    Update to 3.3.17-1

  • gnutls28 Ubuntu:16.04:LTS

    Affected ranges
    • ECOSYSTEM: < 3.3.15-5ubuntu2

    Update to 3.3.15-5ubuntu2

Original sources

Check your server →