CVE-2015-7503
CVE-2015-7503
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.
CVSS 7.5 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
zendframework/zendframework Packagist
- Versions
- 2.5.0
- 2.5.1
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.2
Update to 2.5.2
zendframework/zend-crypt Packagist
- Versions
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.2.0
- 2.2.0rc1
- 2.2.0rc2
- 2.2.0rc3
- 2.2.1
- 2.2.10
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 2.3.9
- 2.4.0
- 2.4.0rc1
- 2.4.0rc2
- 2.4.0rc3
- 2.4.0rc4
- 2.4.0rc5
- 2.4.0rc6
- 2.4.0rc7
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.4.9
Update to 2.4.9
zendframework/zend-crypt Packagist
- Versions
- 2.5.0
- 2.5.1
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.2
Update to 2.5.2
zendframework/zendframework Packagist
- Versions
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.2.0
- 2.2.0rc1
- 2.2.0rc2
- 2.2.0rc3
- 2.2.1
- 2.2.10
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 2.3.9
- 2.4.0
- 2.4.0rc1
- 2.4.0rc2
- 2.4.0rc3
- 2.4.0rc4
- 2.4.0rc5
- 2.4.0rc6
- 2.4.0rc7
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.4.9
Update to 2.4.9