p PatchFirst

CVE-2015-7511

CVE-2015-7511

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Libgcrypt before 1.6.5 does not properly perform elliptic-point curve multiplication during decryption, which makes it easier for physically proximate attackers to extract ECDH keys by measuring electromagnetic emanations.

CVSS 2.0 · Low · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libgcrypt20 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.5-2

    Update to 1.6.5-2

  • libgcrypt20 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.5-2

    Update to 1.6.5-2

  • libgcrypt20 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.5-2

    Update to 1.6.5-2

  • libgcrypt11 Ubuntu:14.04:LTS

    Versions
    • 1.5.0-3ubuntu3
    • 1.5.3-2ubuntu1
    • 1.5.3-2ubuntu4
    • 1.5.3-2ubuntu4.1
    • 1.5.3-2ubuntu4.2
    Affected ranges
    • ECOSYSTEM: < 1.5.3-2ubuntu4.3

    Update to 1.5.3-2ubuntu4.3

Original sources

Check your server →