p PatchFirst

PatchFirst · Latest vulnerabilities

libgcrypt11 vulnerabilities

Vulnerabilities published for libgcrypt11 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2015-0837

    Medium · CVSS 5.9EPSS 1.95%Fix available

    CVE-2015-0837

    The mpi_powm function in Libgcrypt before 1.6.3 and GnuPG before 1.4.19 allows attackers to obtain sensitive information by leveraging timing differences when accessing a pre-computed table during modular exponentiation, related to a "Last-Level Cache Side-Channel Attack."

    • Update to 1.5.3-2ubuntu4.2
    Published Updated
  2. CVE-2014-3591

    Medium · CVSS 4.2EPSS 0.6%Fix available

    CVE-2014-3591

    Libgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determining factors using crafted ciphertext and the fluctuations in the electromagnetic field during multiplication.

    • Update to 1.5.3-2ubuntu4.2
    Published Updated
  3. CVE-2017-7526

    Medium · CVSS 6.1EPSS 3.84%Fix available

    CVE-2017-7526

    libgcrypt before version 1.7.8 is vulnerable to a cache side-channel attack resulting into a complete break of RSA-1024 while using the left-to-right method for computing the sliding-window expansion. The same attack is believed to work on RSA-2048 with moderately more computation. This side-channel requires that attacker can run arbitrary software on the hardware where the private RSA key is used.

    • Update to 1.5.3-2ubuntu4.5
    Published Updated
  4. CVE-2018-0495

    Medium · CVSS 4.7EPSS 0.87%Fix available

    CVE-2018-0495

    Libgcrypt before 1.7.10 and 1.8.x before 1.8.3 allows a memory-cache side-channel attack on ECDSA signatures that can be mitigated through the use of blinding during the signing process in the _gcry_ecc_ecdsa_sign function in cipher/ecc-ecdsa.c, aka the Return Of the Hidden Number Problem or ROHNP. To discover an ECDSA key, the attacker needs access to either the local machine or a different virtual machine on the same physical host.

    • Update to 1.5.3-2ubuntu4.6
    Published Updated
  5. CVE-2014-5270

    Not ratedEPSS 0.53%Fix available

    CVE-2014-5270

    Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

    • Update to 1.5.3-2ubuntu4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →