p PatchFirst

CVE-2015-7674

CVE-2015-7674

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in the pixops_scale_nearest function in pixops/pixops.c in gdk-pixbuf before 2.32.1 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted GIF image file, which triggers a heap-based buffer overflow.

EPSS 5.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gdk-pixbuf Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.32.1-1

    Update to 2.32.1-1

  • gdk-pixbuf Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.32.1-1

    Update to 2.32.1-1

  • gdk-pixbuf Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.32.1-1

    Update to 2.32.1-1

  • gtk+2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.21.5-1

    Update to 2.21.5-1

  • gtk+2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.21.5-1

    Update to 2.21.5-1

  • gtk+2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.21.5-1

    Update to 2.21.5-1

  • gdk-pixbuf Ubuntu:14.04:LTS

    Versions
    • 2.28.1-1ubuntu2
    • 2.30.0-0ubuntu2
    • 2.30.1-0ubuntu2
    • 2.30.2-0ubuntu1
    • 2.30.2-0ubuntu2
    • 2.30.3-0ubuntu1
    • 2.30.4-0ubuntu1
    • 2.30.5-0ubuntu1
    • 2.30.6-1
    • 2.30.7-0ubuntu1
    • 2.30.7-0ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 2.30.7-0ubuntu1.2

    Update to 2.30.7-0ubuntu1.2

Original sources

Check your server →