p PatchFirst

CVE-2015-7941

CVE-2015-7941

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libxml2 2.9.2 does not properly stop parsing invalid input, which allows context-dependent attackers to cause a denial of service (out-of-bounds read and libxml2 crash) via crafted XML data to the (1) xmlParseEntityDecl or (2) xmlParseConditionalSections function in parser.c, as demonstrated by non-terminated entities.

EPSS 3.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.2+really2.9.1+dfsg1-0.1

    Update to 2.9.2+really2.9.1+dfsg1-0.1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.2+really2.9.1+dfsg1-0.1

    Update to 2.9.2+really2.9.1+dfsg1-0.1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.2+really2.9.1+dfsg1-0.1

    Update to 2.9.2+really2.9.1+dfsg1-0.1

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.5

    Update to 2.9.1+dfsg1-3ubuntu4.5

Original sources

Check your server →