p PatchFirst

PatchFirst · Latest vulnerabilities

libxml2 vulnerabilities

Vulnerabilities published for libxml2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 49

  1. CVE-2018-14404

    Medium · CVSS 6.5EPSS 3.75%Fix available

    CVE-2018-14404

    A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.

    • Update to 2.9.1+dfsg1-3ubuntu4.13
    Published Updated
  2. CVE-2017-7375

    Critical · CVSS 9.8EPSS 2.98%Fix available

    CVE-2017-7375

    A flaw in libxml2 allows remote XML entity inclusion with default parser flags (i.e., when the caller did not request entity substitution, DTD validation, external DTD subset loading, or default DTD attributes). Depending on the context, this may expose a higher-risk attack surface in libxml2 not usually reachable with default parser flags, and expose content from local files, HTTP, or FTP servers (which might be otherwise unreachable).

    • Update to 2.9.1+dfsg1-3ubuntu4.10
    Published Updated
  3. CVE-2017-0663

    High · CVSS 7.8EPSS 2.32%Fix available

    CVE-2017-0663

    A remote code execution vulnerability in libxml2 could enable an attacker using a specially crafted file to execute arbitrary code within the context of an unprivileged process. This issue is rated as High due to the possibility of remote code execution in an application that uses this library. Product: Android. Versions: 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2. Android ID: A-37104170.

    • Update to 2.9.1+dfsg1-3ubuntu4.10
    Published Updated
  4. CVE-2017-9050

    High · CVSS 7.5EPSS 4.63%Fix available

    CVE-2017-9050

    libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839.

    • Update to 2.9.1+dfsg1-3ubuntu4.10
    Published Updated
  5. CVE-2017-9049

    High · CVSS 7.5EPSS 4.63%Fix available

    CVE-2017-9049

    libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictComputeFastKey function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for libxml2 Bug 759398.

    • Update to 2.9.1+dfsg1-3ubuntu4.10
    Published Updated
  6. CVE-2017-9048

    High · CVSS 7.5EPSS 4.85%Fix available

    CVE-2017-9048

    libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a stack-based buffer overflow. The function xmlSnprintfElementContent in valid.c is supposed to recursively dump the element content definition into a char buffer 'buf' of size 'size'. At the end of the routine, the function may strcat two more characters without checking whether the current strlen(buf) + 2 < size. This vulnerability causes programs that use libxml2, such as PHP, to crash.

    • Update to 2.9.1+dfsg1-3ubuntu4.10
    Published Updated
  7. CVE-2017-9047

    High · CVSS 7.5EPSS 3.16%Fix available

    CVE-2017-9047

    A buffer overflow was discovered in libxml2 20904-GITv2.9.4-16-g0741801. The function xmlSnprintfElementContent in valid.c is supposed to recursively dump the element content definition into a char buffer 'buf' of size 'size'. The variable len is assigned strlen(buf). If the content->type is XML_ELEMENT_CONTENT_ELEMENT, then (i) the content->prefix is appended to buf (if it actually fits) whereupon (ii) content->name is written to the buffer. However, the check for whether the content->name actually fits also uses 'len' rather than the updated buffer length strlen(buf). This allows us to write about "size" many bytes beyond the allocated memo

    • Update to 2.9.1+dfsg1-3ubuntu4.10
    Published Updated
  8. CVE-2016-4483

    High · CVSS 7.5EPSS 6%Fix available

    CVE-2016-4483

    The xmlBufAttrSerializeTxtContent function in xmlsave.c in libxml2 allows context-dependent attackers to cause a denial of service (out-of-bounds read and application crash) via a non-UTF-8 attribute value, related to serialization. NOTE: this vulnerability may be a duplicate of CVE-2016-3627.

    • Update to 2.9.1+dfsg1-3ubuntu4.8
    Published Updated
  9. CVE-2016-9318

    Medium · CVSS 5.5EPSS 2.94%Fix available

    CVE-2016-9318

    libxml2 2.9.4 and earlier, as used in XMLSec 1.2.23 and earlier and other products, does not offer a flag directly indicating that the current document may be read but other files may not be opened, which makes it easier for remote attackers to conduct XML External Entity (XXE) attacks via a crafted document.

    • Update to 2.9.1+dfsg1-3ubuntu4.13
    Published Updated
  10. CVE-2016-4658

    Critical · CVSS 9.8EPSS 8.56%Fix available

    CVE-2016-4658

    xpointer.c in libxml2 before 2.9.5 (as used in Apple iOS before 10, OS X before 10.12, tvOS before 10, and watchOS before 3, and other products) does not forbid namespace nodes in XPointer ranges, which allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free and memory corruption) via a crafted XML document.

    • Update to 2.9.1+dfsg1-3ubuntu4.9
    Published Updated
  11. CVE-2016-4449

    High · CVSS 7.1EPSS 1.66%Fix available

    CVE-2016-4449

    XML external entity (XXE) vulnerability in the xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.4, when not in validating mode, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via unspecified vectors.

    • Update to 2.9.1+dfsg1-3ubuntu4.8
    Published Updated
  12. CVE-2016-1840

    High · CVSS 7.8EPSS 3.24%Fix available

    CVE-2016-1840

    Heap-based buffer overflow in the xmlFAParsePosCharGroup function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted XML document.

    • Update to 2.9.1+dfsg1-3ubuntu4.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →