p PatchFirst

CVE-2015-7942

CVE-2015-7942

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

The xmlParseConditionalSections function in parser.c in libxml2 does not properly skip intermediary entities when it stops parsing invalid input, which allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via crafted XML data, a different vulnerability than CVE-2015-7941.

EPSS 4.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1

    Update to 2.9.3+dfsg1-1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1

    Update to 2.9.3+dfsg1-1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1

    Update to 2.9.3+dfsg1-1

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.5

    Update to 2.9.1+dfsg1-3ubuntu4.5

Original sources

Check your server →