p PatchFirst

CVE-2015-8317

CVE-2015-8317

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

The xmlParseXMLDecl function in parser.c in libxml2 before 2.9.3 allows context-dependent attackers to obtain sensitive information via an (1) unterminated encoding value or (2) incomplete XML declaration in XML data, which triggers an out-of-bounds heap read.

EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.2+zdfsg1-4

    Update to 2.9.2+zdfsg1-4

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.2+zdfsg1-4

    Update to 2.9.2+zdfsg1-4

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.2+zdfsg1-4

    Update to 2.9.2+zdfsg1-4

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    • 2.9.1+dfsg1-3ubuntu4.5
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.6

    Update to 2.9.1+dfsg1-3ubuntu4.6

Original sources

Check your server →