p PatchFirst

CVE-2015-8386

CVE-2015-8386

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PCRE before 8.38 mishandles the interaction of lookbehind assertions and mutually recursive subpatterns, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

CVSS 9.8 · Critical · EPSS 6.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:8.38-1

    Update to 2:8.38-1

  • pcre3 Ubuntu:14.04:LTS

    Versions
    • 1:8.31-2
    • 1:8.31-2ubuntu2
    • 1:8.31-2ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 1:8.31-2ubuntu2.2

    Update to 1:8.31-2ubuntu2.2

Original sources

Check your server →