p PatchFirst

CVE-2015-8387

CVE-2015-8387

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PCRE before 8.38 mishandles (?123) subroutine calls and related subroutine calls, which allows remote attackers to cause a denial of service (integer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

CVSS 7.3 · High · EPSS 3.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:8.38-1

    Update to 2:8.38-1

  • pcre3 Ubuntu:14.04:LTS

    Versions
    • 1:8.31-2
    • 1:8.31-2ubuntu2
    • 1:8.31-2ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 1:8.31-2ubuntu2.2

    Update to 1:8.31-2ubuntu2.2

Original sources

Check your server →