p PatchFirst

CVE-2015-8865

CVE-2015-8865

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The file_check_mem function in funcs.c in file before 5.23, as used in the Fileinfo component in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5, mishandles continuation-level jumps, which allows context-dependent attackers to cause a denial of service (buffer overflow and application crash) or possibly execute arbitrary code via a crafted magic file.

CVSS 7.3 · High · EPSS 5.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • file Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:5.24-1

    Update to 1:5.24-1

  • file Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:5.24-1

    Update to 1:5.24-1

  • file Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:5.24-1

    Update to 1:5.24-1

  • file Ubuntu:14.04:LTS

    Versions
    • 5.11-2ubuntu4
    • 1:5.14-2ubuntu1
    • 1:5.14-2ubuntu2
    • 1:5.14-2ubuntu3
    • 1:5.14-2ubuntu3.1
    • 1:5.14-2ubuntu3.2
    • 1:5.14-2ubuntu3.3
    Affected ranges
    • ECOSYSTEM: < 1:5.14-2ubuntu3.4

    Update to 1:5.14-2ubuntu3.4

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    • 5.5.9+dfsg-1ubuntu4.6
    • 5.5.9+dfsg-1ubuntu4.7
    • 5.5.9+dfsg-1ubuntu4.9
    • 5.5.9+dfsg-1ubuntu4.11
    • 5.5.9+dfsg-1ubuntu4.12
    • 5.5.9+dfsg-1ubuntu4.13
    • 5.5.9+dfsg-1ubuntu4.14
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.16

    Update to 5.5.9+dfsg-1ubuntu4.16

  • php7.0 Ubuntu:16.04:LTS

    Versions
    • 7.0.1-5
    • 7.0.1-6
    • 7.0.2-1
    • 7.0.2-3
    • 7.0.2-4
    • 7.0.2-5
    • 7.0.3-2
    • 7.0.3-3
    • 7.0.3-9ubuntu1
    • 7.0.4-5ubuntu1
    • 7.0.4-5ubuntu2
    • 7.0.4-7ubuntu1
    • 7.0.4-7ubuntu2
    Affected ranges
    • ECOSYSTEM: < 7.0.4-7ubuntu2.1

    Update to 7.0.4-7ubuntu2.1

Original sources

Check your server →