p PatchFirst

CVE-2015-8868

CVE-2015-8868

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based buffer overflow in the ExponentialFunction::ExponentialFunction function in Poppler before 0.40.0 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via an invalid blend mode in the ExtGState dictionary in a crafted PDF document.

CVSS 7.8 · High · EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • poppler Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.38.0-3

    Update to 0.38.0-3

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.38.0-3

    Update to 0.38.0-3

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.38.0-3

    Update to 0.38.0-3

  • poppler Ubuntu:14.04:LTS

    Versions
    • 0.24.1-0ubuntu1
    • 0.24.3-0ubuntu1
    • 0.24.3-0ubuntu2
    • 0.24.3-0ubuntu3
    • 0.24.3-0ubuntu4
    • 0.24.3-0ubuntu5
    • 0.24.3-0ubuntu6
    • 0.24.3-0ubuntu7
    • 0.24.3-0ubuntu8
    • 0.24.3-0ubuntu10
    • 0.24.3-0ubuntu12
    • 0.24.5-0ubuntu3
    • 0.24.5-2ubuntu1
    • 0.24.5-2ubuntu2
    • 0.24.5-2ubuntu4
    • 0.24.5-2ubuntu4.1
    • 0.24.5-2ubuntu4.2
    • 0.24.5-2ubuntu4.3
    Affected ranges
    • ECOSYSTEM: < 0.24.5-2ubuntu4.4

    Update to 0.24.5-2ubuntu4.4

Original sources

Check your server →