p PatchFirst

PatchFirst · Latest vulnerabilities

poppler vulnerabilities

Vulnerabilities published for poppler in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 31

  1. CVE-2019-9200

    High · CVSS 8.8EPSS 3.47%Fix available

    CVE-2019-9200

    A heap-based buffer underwrite exists in ImageStream::getLine() located at Stream.cc in Poppler 0.74.0 that can (for example) be triggered by sending a crafted PDF file to the pdfimages binary. It allows an attacker to cause Denial of Service (Segmentation fault) or possibly have unspecified other impact.

    • Update to 0.24.5-2ubuntu4.17
    Published Updated
  2. CVE-2019-7310

    High · CVSS 8.8EPSS 2.07%Fix available

    CVE-2019-7310

    In Poppler 0.73.0, a heap-based buffer over-read (due to an integer signedness error in the XRef::getEntry function in XRef.cc) allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document, as demonstrated by pdftocairo.

    • Update to 0.24.5-2ubuntu4.16
    Published Updated
  3. CVE-2018-20481

    Medium · CVSS 6.5EPSS 3.29%Fix available

    CVE-2018-20481

    XRef::getEntry in XRef.cc in Poppler 0.72.0 mishandles unallocated XRef entries, which allows remote attackers to cause a denial of service (NULL pointer dereference) via a crafted PDF document, when XRefEntry::setFlag in XRef.h is called from Parser::makeStream in Parser.cc.

    • Update to 0.24.5-2ubuntu4.15
    Published Updated
  4. CVE-2018-13988

    Medium · CVSS 6.5EPSS 3.11%Fix available

    CVE-2018-13988

    Poppler through 0.62 contains an out of bounds read vulnerability due to an incorrect memory access that is not mapped in its memory space, as demonstrated by pdfunite. This can result in memory corruption and denial of service. This may be exploitable when a victim opens a specially crafted PDF file.

    • Update to 0.24.5-2ubuntu4.12
    Published Updated
  5. CVE-2017-14929

    High · CVSS 7.5EPSS 1.38%Fix available

    CVE-2017-14929

    In Poppler 0.59.0, memory corruption occurs in a call to Object::dictLookup() in Object.h after a repeating series of Gfx::display, Gfx::go, Gfx::execOp, Gfx::opFill, Gfx::doPatternFill, Gfx::doTilingPatternFill and Gfx::drawForm calls (aka a Gfx.cc infinite loop), a different vulnerability than CVE-2017-14519.

    • Update to 0.24.5-2ubuntu4.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →