p PatchFirst

CVE-2015-8983

CVE-2015-8983

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in the _IO_wstr_overflow function in libio/wstrops.c in the GNU C Library (aka glibc or libc6) before 2.22 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors related to computing a size in bytes, which triggers a heap-based buffer overflow.

CVSS 8.1 · High · EPSS 4.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.21-1

    Update to 2.21-1

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.21-1

    Update to 2.21-1

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.21-1

    Update to 2.21-1

  • eglibc Ubuntu:14.04:LTS

    Versions
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    Affected ranges
    • ECOSYSTEM: < 2.19-0ubuntu6.10

    Update to 2.19-0ubuntu6.10

Original sources

Check your server →