CVE-2016-10707
CVE-2016-10707
This page contains facts from public vulnerability sources. Check the original advisory before updating.
jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.
CVSS 7.5 · High · EPSS 3.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
jquery npm
- Versions
- 3.0.0-rc.1
- Affected ranges
- SEMVER: ≥ 3.0.0-rc.1, < 3.0.0
Update to 3.0.0
jquery NuGet
- Versions
- 3.0.0-rc.1
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0-rc.1, < 3.0.0
Update to 3.0.0
org.webjars.npm:jquery Maven
- Versions
- 3.0.0-rc1
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0-rc1, < 3.0.0
Update to 3.0.0
jquery-rails RubyGems
- Versions
- 3.0.0-rc.1
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0-rc.1, < 3.0.0
Update to 3.0.0