p PatchFirst

CVE-2016-10743

CVE-2016-10743

This page contains facts from public vulnerability sources. Check the original advisory before updating.

hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.

CVSS 7.5 · High · EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:2.6-7

    Update to 2:2.6-7

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:2.6-7

    Update to 2:2.6-7

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:2.6-7

    Update to 2:2.6-7

  • wpa Ubuntu:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    • 2.1-0ubuntu1.3
    • 2.1-0ubuntu1.4
    • 2.1-0ubuntu1.5
    • 2.1-0ubuntu1.6
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.7

    Update to 2.1-0ubuntu1.7

  • wpa Ubuntu:16.04:LTS

    Versions
    • 2.4-0ubuntu3
    • 2.4-0ubuntu4
    • 2.4-0ubuntu5
    • 2.4-0ubuntu6
    • 2.4-0ubuntu6.2
    • 2.4-0ubuntu6.3
    Affected ranges
    • ECOSYSTEM: < 2.4-0ubuntu6.4

    Update to 2.4-0ubuntu6.4

Original sources

Check your server →