CVE-2016-1935
CVE-2016-1935
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow in the BufferSubData function in Mozilla Firefox before 44.0 and Firefox ESR 38.x before 38.6 allows remote attackers to execute arbitrary code via crafted WebGL content.
CVSS 8.8 · High · EPSS 5.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 44.0+build3-0ubuntu0.14.04.1
Update to 44.0+build3-0ubuntu0.14.04.1
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- 1:31.4.0+build1-0ubuntu0.14.04.1
- 1:31.5.0+build1-0ubuntu0.14.04.1
- 1:31.6.0+build1-0ubuntu0.14.04.1
- 1:31.7.0+build1-0ubuntu0.14.04.1
- 1:31.8.0+build1-0ubuntu0.14.04.1
- 1:38.2.0+build1-0ubuntu0.14.04.1
- 1:38.3.0+build1-0ubuntu0.14.04.1
- 1:38.4.0+build3-0ubuntu0.14.04.1
- 1:38.5.1+build2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:38.6.0+build1-0ubuntu0.14.04.1
Update to 1:38.6.0+build1-0ubuntu0.14.04.1
Original sources
- http://www.debian.org/security/2016/dsa-3457
- http://www.debian.org/security/2016/dsa-3491
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00105.html
- http://www.securitytracker.com/id/1034825
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://rhn.redhat.com/errata/RHSA-2016-0071.html
- http://www.ubuntu.com/usn/USN-2880-1
- http://www.ubuntu.com/usn/USN-2880-2
- http://rhn.redhat.com/errata/RHSA-2016-0258.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1220450
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00002.html
- http://www.ubuntu.com/usn/USN-2904-1
- https://security.gentoo.org/glsa/201605-06
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00101.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00003.html
- http://www.mozilla.org/security/announce/2016/mfsa2016-03.html
- http://www.securityfocus.com/bid/81952
- https://nvd.nist.gov/vuln/detail/CVE-2016-1935