CVE-2016-1950
CVE-2016-1950
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
Heap-based buffer overflow in Mozilla Network Security Services (NSS) before 3.19.2.3 and 3.20.x and 3.21.x before 3.21.1, as used in Mozilla Firefox before 45.0 and Firefox ESR 38.x before 38.7, allows remote attackers to execute arbitrary code via crafted ASN.1 data in an X.509 certificate.
CVSS 8.8 · High · EPSS 4.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox-esr Debian:12
- Affected ranges
- ECOSYSTEM: < 45.0esr-1
Update to 45.0esr-1
firefox-esr Debian:13
- Affected ranges
- ECOSYSTEM: < 45.0esr-1
Update to 45.0esr-1
firefox-esr Debian:14
- Affected ranges
- ECOSYSTEM: < 45.0esr-1
Update to 45.0esr-1
nss Debian:12
- Affected ranges
- ECOSYSTEM: < 2:3.23-1
Update to 2:3.23-1
nss Debian:13
- Affected ranges
- ECOSYSTEM: < 2:3.23-1
Update to 2:3.23-1
nss Debian:14
- Affected ranges
- ECOSYSTEM: < 2:3.23-1
Update to 2:3.23-1
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- 44.0+build3-0ubuntu0.14.04.1
- 44.0.1+build2-0ubuntu0.14.04.1
- 44.0.2+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 45.0+build2-0ubuntu0.14.04.1
Update to 45.0+build2-0ubuntu0.14.04.1
nss Ubuntu:14.04:LTS
- Versions
- 2:3.15.1-1ubuntu1
- 2:3.15.2-1
- 2:3.15.3-1
- 2:3.15.3.1-1
- 2:3.15.3.1-1.1
- 2:3.15.3.1-1.1ubuntu1
- 2:3.15.4-1ubuntu3
- 2:3.15.4-1ubuntu4
- 2:3.15.4-1ubuntu5
- 2:3.15.4-1ubuntu6
- 2:3.15.4-1ubuntu7
- 2:3.15.4-1ubuntu7.1
- 2:3.17-0ubuntu0.14.04.1
- 2:3.17.1-0ubuntu0.14.04.1
- 2:3.17.1-0ubuntu0.14.04.2
- 2:3.17.4-0ubuntu0.14.04.1
- 2:3.19.2-0ubuntu0.14.04.1
- 2:3.19.2.1-0ubuntu0.14.04.1
- 2:3.19.2.1-0ubuntu0.14.04.2
- 2:3.21-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 2:3.21-0ubuntu0.14.04.2
Update to 2:3.21-0ubuntu0.14.04.2
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- 1:31.4.0+build1-0ubuntu0.14.04.1
- 1:31.5.0+build1-0ubuntu0.14.04.1
- 1:31.6.0+build1-0ubuntu0.14.04.1
- 1:31.7.0+build1-0ubuntu0.14.04.1
- 1:31.8.0+build1-0ubuntu0.14.04.1
- 1:38.2.0+build1-0ubuntu0.14.04.1
- 1:38.3.0+build1-0ubuntu0.14.04.1
- 1:38.4.0+build3-0ubuntu0.14.04.1
- 1:38.5.1+build2-0ubuntu0.14.04.1
- 1:38.6.0+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:38.7.2+build1-0ubuntu0.14.04.1
Update to 1:38.7.2+build1-0ubuntu0.14.04.1
nss Ubuntu:16.04:LTS
- Versions
- 2:3.19.2-1ubuntu1
- 2:3.19.2.1-0ubuntu1
- 2:3.21-1ubuntu2
- 2:3.21-1ubuntu3
- Affected ranges
- ECOSYSTEM: < 2:3.21-1ubuntu4
Update to 2:3.21-1ubuntu4
thunderbird Ubuntu:16.04:LTS
- Versions
- 1:38.3.0+build1-0ubuntu2
- 1:38.5.1+build2-0ubuntu1
- 1:38.6.0+build1-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 1:38.7.2+build1-0ubuntu0.16.04.1
Update to 1:38.7.2+build1-0ubuntu0.16.04.1
Original sources
- http://www.oracle.com/technetwork/topics/security/ovmbulletinjul2016-3090546.html
- https://bto.bluecoat.com/security-advisory/sa119
- http://www.debian.org/security/2016/dsa-3688
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00016.html
- http://lists.apple.com/archives/security-announce/2016/Mar/msg00004.html
- http://www.mozilla.org/security/announce/2016/mfsa2016-35.html
- https://support.apple.com/HT206167
- https://support.apple.com/HT206168
- http://www.securityfocus.com/bid/84223
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00068.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://lists.apple.com/archives/security-announce/2016/Mar/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00029.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00027.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
- http://www.ubuntu.com/usn/USN-2917-1
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://lists.apple.com/archives/security-announce/2016/Mar/msg00001.html
- http://www.debian.org/security/2016/dsa-3520
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00093.html
- http://www.debian.org/security/2016/dsa-3510
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00031.html
- http://www.ubuntu.com/usn/USN-2924-1
- https://nvd.nist.gov/vuln/detail/CVE-2016-1950