CVE-2016-1951
CVE-2016-1951
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple integer overflows in io/prprf.c in Mozilla Netscape Portable Runtime (NSPR) before 4.12 allow remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a long string to a PR_*printf function.
CVSS 8.6 · High · EPSS 3.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox-esr Debian:12
- Affected ranges
- ECOSYSTEM: < 45.0esr-1
Update to 45.0esr-1
firefox-esr Debian:13
- Affected ranges
- ECOSYSTEM: < 45.0esr-1
Update to 45.0esr-1
firefox-esr Debian:14
- Affected ranges
- ECOSYSTEM: < 45.0esr-1
Update to 45.0esr-1
nspr Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.12-1
Update to 2:4.12-1
nspr Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.12-1
Update to 2:4.12-1
nspr Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.12-1
Update to 2:4.12-1
nspr Ubuntu:14.04:LTS
- Versions
- 2:4.9.5-1ubuntu1
- 2:4.9.5-1ubuntu2
- 2:4.10.2-1ubuntu1
- 2:4.10.2-1ubuntu1.1
- 2:4.10.7-0ubuntu0.14.04.1
- 2:4.10.10-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 2:4.12-0ubuntu0.14.04.1
Update to 2:4.12-0ubuntu0.14.04.1
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- 1:31.4.0+build1-0ubuntu0.14.04.1
- 1:31.5.0+build1-0ubuntu0.14.04.1
- 1:31.6.0+build1-0ubuntu0.14.04.1
- 1:31.7.0+build1-0ubuntu0.14.04.1
- 1:31.8.0+build1-0ubuntu0.14.04.1
- 1:38.2.0+build1-0ubuntu0.14.04.1
- 1:38.3.0+build1-0ubuntu0.14.04.1
- 1:38.4.0+build3-0ubuntu0.14.04.1
- 1:38.5.1+build2-0ubuntu0.14.04.1
- 1:38.6.0+build1-0ubuntu0.14.04.1
- 1:38.7.2+build1-0ubuntu0.14.04.1
- 1:38.8.0+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:45.2.0+build1-0ubuntu0.14.04.3
Update to 1:45.2.0+build1-0ubuntu0.14.04.3
nspr Ubuntu:16.04:LTS
- Versions
- 2:4.10.8-2ubuntu1
- 2:4.10.10-1ubuntu1
- 2:4.11-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2:4.12-0ubuntu0.16.04.1
Update to 2:4.12-0ubuntu0.16.04.1
thunderbird Ubuntu:16.04:LTS
- Versions
- 1:38.3.0+build1-0ubuntu2
- 1:38.5.1+build2-0ubuntu1
- 1:38.6.0+build1-0ubuntu1
- 1:38.7.2+build1-0ubuntu0.16.04.1
- 1:38.8.0+build1-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 1:45.2.0+build1-0ubuntu0.16.04.1
Update to 1:45.2.0+build1-0ubuntu0.16.04.1
Original sources
- https://groups.google.com/forum/message/raw?msg=mozilla.dev.tech.nspr/dV4MyMsg6jw/hhWcXOgJDQAJ
- http://www.securityfocus.com/bid/92385
- http://www.securitytracker.com/id/1036590
- https://hg.mozilla.org/projects/nspr/rev/96381e3aaae2
- https://bugzilla.mozilla.org/show_bug.cgi?id=1174015
- http://www.ubuntu.com/usn/USN-3023-1
- https://nvd.nist.gov/vuln/detail/CVE-2016-1951