CVE-2016-2039
CVE-2016-2039
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libraries/session.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not properly generate CSRF token values, which allows remote attackers to bypass intended access restrictions by predicting a value.
CVSS 5.3 · Medium · EPSS 2.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
phpmyadmin Debian:12
- Affected ranges
- ECOSYSTEM: < 4:4.5.4-1
Update to 4:4.5.4-1
phpmyadmin Debian:13
- Affected ranges
- ECOSYSTEM: < 4:4.5.4-1
Update to 4:4.5.4-1
phpmyadmin Debian:14
- Affected ranges
- ECOSYSTEM: < 4:4.5.4-1
Update to 4:4.5.4-1
phpmyadmin Ubuntu:Pro:14.04:LTS
- Versions
- 4:4.0.6-1
- 4:4.0.8-1
- 4:4.0.9-1
- 4:4.0.10-1
- 4:4.0.10-1ubuntu0.1
- 4:4.0.10-1ubuntu0.1+esm1
- 4:4.0.10-1ubuntu0.1+esm2
- 4:4.0.10-1ubuntu0.1+esm3
- 4:4.0.10-1ubuntu0.1+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/phpmyadmin/phpmyadmin/commit/f20970d32c3dfdf82aef7b6c244da1f769043813
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00049.html
- http://www.debian.org/security/2016/dsa-3627
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00028.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176739.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176483.html
- http://www.phpmyadmin.net/home_page/security/PMASA-2016-2.php
- https://github.com/phpmyadmin/phpmyadmin/commit/cb7748ac9cffcd1cd0f3081499cd4aafa9d1065e
- https://nvd.nist.gov/vuln/detail/CVE-2016-2039