p PatchFirst

CVE-2016-2106

CVE-2016-2106

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Integer overflow in the EVP_EncryptUpdate function in crypto/evp/evp_enc.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to cause a denial of service (heap memory corruption) via a large amount of data.

CVSS 7.5 · High · EPSS 27.3% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.2h-1

    Update to 1.0.2h-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.2h-1

    Update to 1.0.2h-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.2h-1

    Update to 1.0.2h-1

  • openssl Ubuntu:14.04:LTS

    Versions
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    Affected ranges
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.19

    Update to 1.0.1f-1ubuntu2.19

  • openssl Ubuntu:16.04:LTS

    Versions
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    Affected ranges
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.1

    Update to 1.0.2g-1ubuntu4.1

Original sources

Check your server →