p PatchFirst

CVE-2016-3705

CVE-2016-3705

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The (1) xmlParserEntityCheck and (2) xmlParseAttValueComplex functions in parser.c in libxml2 2.9.3 do not properly keep track of the recursion depth, which allows context-dependent attackers to cause a denial of service (stack consumption and application crash) via a crafted XML document containing a large number of nested entity references.

CVSS 7.5 · High · EPSS 5.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1.1

    Update to 2.9.3+dfsg1-1.1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1.1

    Update to 2.9.3+dfsg1-1.1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1.1

    Update to 2.9.3+dfsg1-1.1

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    • 2.9.1+dfsg1-3ubuntu4.5
    • 2.9.1+dfsg1-3ubuntu4.6
    • 2.9.1+dfsg1-3ubuntu4.7
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.8

    Update to 2.9.1+dfsg1-3ubuntu4.8

  • libxml2 Ubuntu:16.04:LTS

    Versions
    • 2.9.2+zdfsg1-4
    • 2.9.2+zdfsg1-4ubuntu1
    • 2.9.2+zdfsg1-4ubuntu2
    • 2.9.2+zdfsg1-4ubuntu3
    • 2.9.3+dfsg1-1
    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.1

    Update to 2.9.3+dfsg1-1ubuntu0.1

Original sources

Check your server →