p PatchFirst

CVE-2016-3956

CVE-2016-3956

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests, which allows remote HTTP servers to obtain sensitive information by reading Authorization headers.

CVSS 7.5 · High · EPSS 5.5% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • npm Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.8.0+ds-2

    Update to 5.8.0+ds-2

  • npm Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.8.0+ds-2

    Update to 5.8.0+ds-2

  • npm Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.8.0+ds-2

    Update to 5.8.0+ds-2

  • npm npm

    Affected ranges
    • SEMVER: < 2.15.1

    Update to 2.15.1

  • npm npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.8.3

    Update to 3.8.3

  • npm Ubuntu:Pro:16.04:LTS

    Versions
    • 1.4.21+ds-2
    • 3.5.2-0ubuntu4
    Affected ranges
    • ECOSYSTEM: < 3.5.2-0ubuntu4.1.16.04.1~esm1

    Update to 3.5.2-0ubuntu4.1.16.04.1~esm1

  • npm Ubuntu:Pro:18.04:LTS

    Versions
    • 3.5.2-0ubuntu4
    Affected ranges
    • ECOSYSTEM: < 3.5.2-0ubuntu4.1.18.04.1~esm1

    Update to 3.5.2-0ubuntu4.1.18.04.1~esm1

Original sources

Check your server →