p PatchFirst

CVE-2016-4476

CVE-2016-4476

This page contains facts from public vulnerability sources. Check the original advisory before updating.

hostapd 0.6.7 through 2.5 and wpa_supplicant 0.6.7 through 2.5 do not reject \n and \r characters in passphrase parameters, which allows remote attackers to cause a denial of service (daemon outage) via a crafted WPS operation.

CVSS 7.5 · High · EPSS 2.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3-2.4

    Update to 2.3-2.4

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3-2.4

    Update to 2.3-2.4

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3-2.4

    Update to 2.3-2.4

  • wpa Ubuntu:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    • 2.1-0ubuntu1.3
    • 2.1-0ubuntu1.4
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.5

    Update to 2.1-0ubuntu1.5

  • wpa Ubuntu:16.04:LTS

    Versions
    • 2.4-0ubuntu3
    • 2.4-0ubuntu4
    • 2.4-0ubuntu5
    • 2.4-0ubuntu6
    Affected ranges
    • ECOSYSTEM: < 2.4-0ubuntu6.2

    Update to 2.4-0ubuntu6.2

  • wpa Ubuntu:18.04:LTS

    Affected ranges
    • ECOSYSTEM: < 2.4-0ubuntu10

    Update to 2.4-0ubuntu10

Original sources

Check your server →